Project

General

Profile

Anomalie #16794

[RM] PHP8 compatibility

Added by Mathieu PIONNIER 7 months ago. Updated 3 months ago.

Status:
Intégré / Développé / Analysé
Priority:
2-Sérieux
Assignee:
-
Target version:
Start date:
04/01/2021
Due date:
Tags RM:
2.8.0

Description

Voici l'ensemble des erreurs remontées par le sniffer https://github.com/PHPCompatibility/PHPCompatibility pour la montée en version 8 de PHP sur AP et sur le socle.

AP :



FILE: /home/mathieu/Documents/archivesPubliques/bundle/seda2/Controller/abstractMessage.php
----------------------------------------------------------------------------------------------------------------------------------------------------------------------
FOUND 1 ERROR AFFECTING 1 LINE
----------------------------------------------------------------------------------------------------------------------------------------------------------------------
 1151 | ERROR | Indirect access to variables, properties and methods will be evaluated strictly in left-to-right order since PHP 7.0. Use curly braces to remove
      |       | ambiguity.
----------------------------------------------------------------------------------------------------------------------------------------------------------------------

Socle :



FILE: ...rchRM/src/bundle/recordsManagement/Controller/archiveModificationTrait.php
--------------------------------------------------------------------------------
FOUND 1 ERROR AFFECTING 1 LINE
--------------------------------------------------------------------------------
 442 | ERROR | Indirect access to variables, properties and methods will be
     |       | evaluated strictly in left-to-right order since PHP 7.0. Use
     |       | curly braces to remove ambiguity.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/core/Kernel/SoapKernel.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 92 | WARNING | Method name "SoapKernel::__dispatch" is discouraged; PHP has
    |         | reserved all method names with a double underscore prefix for
    |         | future use.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/core/laabsAppTrait.php
--------------------------------------------------------------------------------
FOUND 1 ERROR AND 3 WARNINGS AFFECTING 4 LINES
--------------------------------------------------------------------------------
 495 | WARNING | Since PHP 7.0, functions inspecting arguments, like
     |         | func_get_args(), no longer report the original value as passed
     |         | to a parameter, but will instead provide the current value.
     |         | The parameter "$name" was used, and possibly changed (by
     |         | reference), on line 492.
 516 | WARNING | Since PHP 7.0, functions inspecting arguments, like
     |         | func_get_args(), no longer report the original value as passed
     |         | to a parameter, but will instead provide the current value.
     |         | The parameter "$name" was used, and possibly changed (by
     |         | reference), on line 513.
 536 | ERROR   | Since PHP 7.0, functions inspecting arguments, like
     |         | func_get_args(), no longer report the original value as passed
     |         | to a parameter, but will instead provide the current value.
     |         | The parameter "$exceptionName" was changed on line 534.
 554 | WARNING | Since PHP 7.0, functions inspecting arguments, like
     |         | func_get_args(), no longer report the original value as passed
     |         | to a parameter, but will instead provide the current value.
     |         | The parameter "$serviceName" was used, and possibly changed
     |         | (by reference), on line 552.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/core/laabsModelTrait.php
--------------------------------------------------------------------------------
FOUND 1 ERROR AFFECTING 1 LINE
--------------------------------------------------------------------------------
 460 | ERROR | Since PHP 7.0, functions inspecting arguments, like
     |       | func_get_args(), no longer report the original value as passed
     |       | to a parameter, but will instead provide the current value. The
     |       | parameter "$className" was changed on line 456.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/core/Type/Number.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
--------------------------------------------------------------------------------
 71 | WARNING | Method name "Number::__toInt" is discouraged; PHP has reserved
    |         | all method names with a double underscore prefix for future
    |         | use.
 80 | WARNING | Method name "Number::__toFloat" is discouraged; PHP has
    |         | reserved all method names with a double underscore prefix for
    |         | future use.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/core/Reflection/Trait.php
--------------------------------------------------------------------------------
FOUND 2 ERRORS AFFECTING 1 LINE
--------------------------------------------------------------------------------
 9 | ERROR | Function name, class name, namespace name or constant name can not
   |       | be reserved keyword 'Trait' (since version 5.4)
 9 | ERROR | Function name, class name, namespace name or constant name can not
   |       | be reserved keyword 'extends' (since version all)
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/core/Reflection/Bundle.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 613 | WARNING | Since PHP 7.0, functions inspecting arguments, like
     |         | func_get_args(), no longer report the original value as passed
     |         | to a parameter, but will instead provide the current value.
     |         | The parameter "$name" was used, and possibly changed (by
     |         | reference), on line 611.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/core/Reflection/Property.php
--------------------------------------------------------------------------------
FOUND 1 ERROR AFFECTING 1 LINE
--------------------------------------------------------------------------------
 224 | ERROR | Indirect access to variables, properties and methods will be
     |       | evaluated strictly in left-to-right order since PHP 7.0. Use
     |       | curly braces to remove ambiguity.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/core/Reflection/Resource.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 11 | WARNING | 'resource' is a soft reserved keyword as of PHP version 7.0 and
    |         | should not be used to name a class, interface or trait or as
    |         | part of a namespace (T_CLASS)
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/SOAP/Transport/HTTP.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
--------------------------------------------------------------------------------
  83 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
 591 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and
     |         | removed since PHP 5.4
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/SOAP/Transport/SMTP.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 61 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/SOAP/Transport/TCP.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 49 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/SOAP/WSDL.php
--------------------------------------------------------------------------------
FOUND 2 ERRORS AFFECTING 1 LINE
--------------------------------------------------------------------------------
 945 | ERROR | Function ereg_replace() is deprecated since PHP 5.3 and removed
     |       | since PHP 7.0; Use preg_replace() instead
 945 | ERROR | Extension 'ereg' is deprecated since PHP 5.3 and removed since
     |       | PHP 7.0; Use pcre instead
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/SOAP/Server.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
--------------------------------------------------------------------------------
  95 | WARNING | INI directive 'track_errors' is deprecated since PHP 7.2
 525 | WARNING | Method name "SOAP_Server::__decodeRequest" is discouraged; PHP
     |         | has reserved all method names with a double underscore prefix
     |         | for future use.
--------------------------------------------------------------------------------


FILE: ...e/mathieu/Documents/maarchRM/dependency/PEAR/SOAP/Server/Email_Gateway.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 47 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/SOAP/Server/Email.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 45 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/SOAP/Server/TCP.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 48 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/SOAP/Type/dateTime.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 62 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/SOAP/Type/duration.php
--------------------------------------------------------------------------------
FOUND 4 ERRORS AFFECTING 2 LINES
--------------------------------------------------------------------------------
 144 | ERROR | Function ereg() is deprecated since PHP 5.3 and removed since
     |       | PHP 7.0; Use preg_match() instead
 144 | ERROR | Extension 'ereg' is deprecated since PHP 5.3 and removed since
     |       | PHP 7.0; Use pcre instead
 152 | ERROR | Function ereg() is deprecated since PHP 5.3 and removed since
     |       | PHP 7.0; Use preg_match() instead
 152 | ERROR | Extension 'ereg' is deprecated since PHP 5.3 and removed since
     |       | PHP 7.0; Use pcre instead
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 97 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/Whois.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 135 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/Ping.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
--------------------------------------------------------------------------------
 125 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
 660 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/URL.php
--------------------------------------------------------------------------------
FOUND 11 ERRORS AND 1 WARNING AFFECTING 8 LINES
--------------------------------------------------------------------------------
 134 | ERROR   | [ ] Global variable '$HTTP_SERVER_VARS' is deprecated since
     |         |     PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
 151 | ERROR   | [ ] Global variable '$HTTP_SERVER_VARS' is deprecated since
     |         |     PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
 152 | ERROR   | [ ] Global variable '$HTTP_SERVER_VARS' is deprecated since
     |         |     PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
 164 | ERROR   | [ ] Global variable '$HTTP_SERVER_VARS' is deprecated since
     |         |     PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
 164 | ERROR   | [ ] Global variable '$HTTP_SERVER_VARS' is deprecated since
     |         |     PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
 165 | ERROR   | [ ] Global variable '$HTTP_SERVER_VARS' is deprecated since
     |         |     PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
 165 | ERROR   | [ ] Global variable '$HTTP_SERVER_VARS' is deprecated since
     |         |     PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
 166 | ERROR   | [ ] Global variable '$HTTP_SERVER_VARS' is deprecated since
     |         |     PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
 166 | ERROR   | [ ] Global variable '$HTTP_SERVER_VARS' is deprecated since
     |         |     PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
 167 | ERROR   | [ ] Global variable '$HTTP_SERVER_VARS' is deprecated since
     |         |     PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
 167 | ERROR   | [ ] Global variable '$HTTP_SERVER_VARS' is deprecated since
     |         |     PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
 193 | WARNING | [x] Curly brace syntax for accessing array elements and string
     |         |     offsets has been deprecated in PHP 7.4. Found: $value{0}
--------------------------------------------------------------------------------
PHPCBF CAN FIX THE 1 MARKED SNIFF VIOLATIONS AUTOMATICALLY
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/FTP/Socket.php
--------------------------------------------------------------------------------
FOUND 1 ERROR AFFECTING 1 LINE
--------------------------------------------------------------------------------
 365 | ERROR | Function split() is deprecated since PHP 5.3 and removed since
     |       | PHP 7.0; Use preg_split() instead
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/FTP/Observer.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 67 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/Question.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 37 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR/SRV.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 42 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR/LOC.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 94 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR/MX.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 40 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR/TXT.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 39 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR/HINFO.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 40 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR/SOA.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 45 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR/NAPTR.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 44 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR/RP.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 41 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR/NS.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 39 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR/TSIG.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 50 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR/CNAME.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 39 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR/A.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 38 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR/PTR.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 39 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR/AAAA.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 39 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/Packet.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 143 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/Resolver.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 260 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/Header.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 140 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS/RR.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 62 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/POP3.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 4 WARNINGS AFFECTING 4 LINES
--------------------------------------------------------------------------------
  54 | WARNING | The "case_insensitive" parameter for function define() is
     |         | deprecated since PHP 7.3
  55 | WARNING | The "case_insensitive" parameter for function define() is
     |         | deprecated since PHP 7.3
  56 | WARNING | The "case_insensitive" parameter for function define() is
     |         | deprecated since PHP 7.3
 150 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/LDAP/Filter.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 92 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/LDAP/Schema.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 107 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/LDAP/Util.php
--------------------------------------------------------------------------------
FOUND 5 ERRORS AND 1 WARNING AFFECTING 6 LINES
--------------------------------------------------------------------------------
  40 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
 120 | ERROR   | preg_replace() - /e modifier is deprecated since PHP 5.5 and
     |         | removed since PHP 7.0
 124 | ERROR   | preg_replace() - /e modifier is deprecated since PHP 5.5 and
     |         | removed since PHP 7.0
 146 | ERROR   | preg_replace() - /e modifier is deprecated since PHP 5.5 and
     |         | removed since PHP 7.0
 150 | ERROR   | preg_replace() - /e modifier is deprecated since PHP 5.5 and
     |         | removed since PHP 7.0
 527 | ERROR   | preg_replace() - /e modifier is deprecated since PHP 5.5 and
     |         | removed since PHP 7.0
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/LDAP/Search.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 115 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/LDAP/LDIF.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 218 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/LDAP/Entry.php
--------------------------------------------------------------------------------
FOUND 2 ERRORS AND 1 WARNING AFFECTING 3 LINES
--------------------------------------------------------------------------------
 143 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
 277 | ERROR   | The "ber_identifier" parameter for function
     |         | ldap_first_attribute() is removed since PHP 5.2.4
 279 | ERROR   | The "ber_identifier" parameter for function
     |         | ldap_next_attribute() is removed since PHP 5.2.4
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/LDAP/RootDSE.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 43 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/FTP.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 9 WARNINGS AFFECTING 7 LINES
--------------------------------------------------------------------------------
   40 | WARNING | [ ] The "case_insensitive" parameter for function define() is
      |         |     deprecated since PHP 7.3
   49 | WARNING | [ ] The "case_insensitive" parameter for function define() is
      |         |     deprecated since PHP 7.3
   58 | WARNING | [ ] The "case_insensitive" parameter for function define() is
      |         |     deprecated since PHP 7.3
   67 | WARNING | [ ] The "case_insensitive" parameter for function define() is
      |         |     deprecated since PHP 7.3
  620 | WARNING | [ ] Use of deprecated PHP4 style class constructor is not
      |         |     supported since PHP 7.
 1058 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $permissions{$i}
 1058 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $permissions{$i}
 1060 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $permissions{$i}
 1060 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $permissions{$i}
--------------------------------------------------------------------------------
PHPCBF CAN FIX THE 4 MARKED SNIFF VIOLATIONS AUTOMATICALLY
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/URL2.php
--------------------------------------------------------------------------------
FOUND 1 ERROR AFFECTING 1 LINE
--------------------------------------------------------------------------------
 649 | ERROR | preg_replace() - /e modifier is deprecated since PHP 5.5 and
     |       | removed since PHP 7.0
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/Socket.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 5 WARNINGS AFFECTING 5 LINES
--------------------------------------------------------------------------------
 140 | WARNING | INI directive 'track_errors' is deprecated since PHP 7.2
 169 | WARNING | The variable '$php_errormsg' is deprecated since PHP 7.2; Use
     |         | error_get_last() instead
 170 | WARNING | The variable '$php_errormsg' is deprecated since PHP 7.2; Use
     |         | error_get_last() instead
 172 | WARNING | INI directive 'track_errors' is deprecated since PHP 7.2
 176 | WARNING | INI directive 'track_errors' is deprecated since PHP 7.2
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DIME.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
--------------------------------------------------------------------------------
 116 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
 395 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/SMTP.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 172 | WARNING | Use of deprecated PHP4 style class constructor is not
     |         | supported since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS2.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 735 | WARNING | Function each() is deprecated since PHP 7.2; Use a foreach
     |         | loop instead
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/LDAP.php
--------------------------------------------------------------------------------
FOUND 5 ERRORS AND 3 WARNINGS AFFECTING 8 LINES
--------------------------------------------------------------------------------
  159 | ERROR   | Assigning the return value of new by reference is deprecated
      |         | in PHP 5.3 and has been removed in PHP 7.0
  187 | WARNING | Use of deprecated PHP4 style class constructor is not
      |         | supported since PHP 7.
  765 | ERROR   | Assigning the return value of new by reference is deprecated
      |         | in PHP 5.3 and has been removed in PHP 7.0
  768 | ERROR   | Assigning the return value of new by reference is deprecated
      |         | in PHP 5.3 and has been removed in PHP 7.0
  777 | ERROR   | Assigning the return value of new by reference is deprecated
      |         | in PHP 5.3 and has been removed in PHP 7.0
 1198 | ERROR   | Assigning the return value of new by reference is deprecated
      |         | in PHP 5.3 and has been removed in PHP 7.0
 1265 | WARNING | Function dl() is deprecated since PHP 5.3
 1417 | WARNING | Use of deprecated PHP4 style class constructor is not
      |         | supported since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/Net/DNS2/RR/CAA.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 115 | WARNING | Passing the $glue and $pieces parameters in reverse order to
     |         | implode has been deprecated since PHP 7.4; $glue should be the
     |         | first parameter and $pieces the second
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/HTTP/Request/Listener.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 70 | WARNING | Use of deprecated PHP4 style class constructor is not supported
    |         | since PHP 7.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/HTTP/Request.php
--------------------------------------------------------------------------------
FOUND 2 ERRORS AND 13 WARNINGS AFFECTING 15 LINES
--------------------------------------------------------------------------------
  63 | WARNING | [ ] The "case_insensitive" parameter for function define() is
     |         |     deprecated since PHP 7.3
  64 | WARNING | [ ] The "case_insensitive" parameter for function define() is
     |         |     deprecated since PHP 7.3
  65 | WARNING | [ ] The "case_insensitive" parameter for function define() is
     |         |     deprecated since PHP 7.3
  66 | WARNING | [ ] The "case_insensitive" parameter for function define() is
     |         |     deprecated since PHP 7.3
  67 | WARNING | [ ] The "case_insensitive" parameter for function define() is
     |         |     deprecated since PHP 7.3
  68 | WARNING | [ ] The "case_insensitive" parameter for function define() is
     |         |     deprecated since PHP 7.3
  69 | WARNING | [ ] The "case_insensitive" parameter for function define() is
     |         |     deprecated since PHP 7.3
  89 | WARNING | [ ] The "case_insensitive" parameter for function define() is
     |         |     deprecated since PHP 7.3
  90 | WARNING | [ ] The "case_insensitive" parameter for function define() is
     |         |     deprecated since PHP 7.3
  93 | WARNING | [ ] INI directive 'mbstring.func_overload' is deprecated since
     |         |     PHP 7.2
 711 | WARNING | [ ] INI directive 'magic_quotes_runtime' is deprecated since
     |         |     PHP 5.3 and removed since PHP 5.4
 712 | ERROR   | [ ] INI directive 'magic_quotes_runtime' is deprecated since
     |         |     PHP 5.3 and removed since PHP 5.4
 769 | ERROR   | [ ] INI directive 'magic_quotes_runtime' is deprecated since
     |         |     PHP 5.3 and removed since PHP 5.4
 797 | WARNING | [x] Curly brace syntax for accessing array elements and string
     |         |     offsets has been deprecated in PHP 7.4. Found:
     |         |     $redirect{0}
 965 | WARNING | [ ] Function create_function() is deprecated since PHP 7.2;
     |         |     Use an anonymous function instead
--------------------------------------------------------------------------------
PHPCBF CAN FIX THE 1 MARKED SNIFF VIOLATIONS AUTOMATICALLY
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PEAR/PEAR.php
--------------------------------------------------------------------------------
FOUND 1 ERROR AND 5 WARNINGS AFFECTING 5 LINES
--------------------------------------------------------------------------------
  55 | WARNING | INI directive 'track_errors' is deprecated since PHP 7.2
 708 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and
     |         | removed since PHP 5.4
 725 | WARNING | Function dl() is deprecated since PHP 5.3
 725 | WARNING | Function dl() is deprecated since PHP 5.3
 750 | WARNING | Function each() is deprecated since PHP 7.2; Use a foreach
     |         | loop instead
 844 | ERROR   | Since PHP 7.0, functions inspecting arguments, like
     |         | debug_backtrace(), no longer report the original value as
     |         | passed to a parameter, but will instead provide the current
     |         | value. The parameter "$mode" was changed on line 830.
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PDF/fpdf/makefont/makefont.php
--------------------------------------------------------------------------------
FOUND 1 ERROR AND 1 WARNING AFFECTING 2 LINES
--------------------------------------------------------------------------------
 387 | WARNING | Function get_magic_quotes_runtime() is deprecated since PHP
     |         | 7.4
 388 | ERROR   | Function set_magic_quotes_runtime() is deprecated since PHP
     |         | 5.3 and removed since PHP 7.0
--------------------------------------------------------------------------------


FILE: /home/mathieu/Documents/maarchRM/dependency/PDF/fpdf/fpdf.php
--------------------------------------------------------------------------------
FOUND 1 ERROR AND 2 WARNINGS AFFECTING 3 LINES
--------------------------------------------------------------------------------
 1060 | WARNING | INI directive 'mbstring.func_overload' is deprecated since
      |         | PHP 7.2
 1065 | WARNING | Function get_magic_quotes_runtime() is deprecated since PHP
      |         | 7.4
 1066 | ERROR   | Function set_magic_quotes_runtime() is deprecated since PHP
      |         | 5.3 and removed since PHP 7.0
--------------------------------------------------------------------------------


FILE: ...archRM/dependency/notification/PHPMailer-master/examples/styles/shCore.css
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 1 | WARNING | File appears to be minified and cannot be processed
--------------------------------------------------------------------------------


FILE: ...archRM/dependency/notification/PHPMailer-master/examples/scripts/shCore.js
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 1 | WARNING | File appears to be minified and cannot be processed
--------------------------------------------------------------------------------


FILE: ...ts/maarchRM/dependency/notification/PHPMailer-master/PHPMailerAutoload.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 45 | WARNING | Use of __autoload() function is deprecated since PHP 7.2
--------------------------------------------------------------------------------


FILE: ...rchRM/dependency/notification/PHPMailer-master/extras/ntlm_sasl_client.php
--------------------------------------------------------------------------------
FOUND 11 ERRORS AFFECTING 3 LINES
--------------------------------------------------------------------------------
 71 | ERROR | Function mcrypt_get_iv_size() is deprecated since PHP 7.1 and
    |       | removed since PHP 7.2; Use OpenSSL instead
 71 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since
    |       | PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available
    |       | instead
 71 | ERROR | The constant "MCRYPT_DES" is deprecated since PHP 7.1 and removed
    |       | since PHP 7.2
 71 | ERROR | The constant "MCRYPT_MODE_ECB" is deprecated since PHP 7.1 and
    |       | removed since PHP 7.2
 72 | ERROR | Function mcrypt_create_iv() is deprecated since PHP 7.1 and
    |       | removed since PHP 7.2; Use random_bytes() or OpenSSL instead
 72 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since
    |       | PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available
    |       | instead
 72 | ERROR | The constant "MCRYPT_RAND" is deprecated since PHP 7.1 and
    |       | removed since PHP 7.2
 82 | ERROR | Function mcrypt_encrypt() is deprecated since PHP 7.1 and removed
    |       | since PHP 7.2; Use OpenSSL instead
 82 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since
    |       | PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available
    |       | instead
 82 | ERROR | The constant "MCRYPT_DES" is deprecated since PHP 7.1 and removed
    |       | since PHP 7.2
 82 | ERROR | The constant "MCRYPT_MODE_ECB" is deprecated since PHP 7.1 and
    |       | removed since PHP 7.2
--------------------------------------------------------------------------------


FILE: ...ts/maarchRM/dependency/notification/PHPMailer-master/extras/htmlfilter.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 30 WARNINGS AFFECTING 26 LINES
--------------------------------------------------------------------------------
   49 | WARNING | [ ] Function each() is deprecated since PHP 7.2; Use a
      |         |     foreach loop instead
  351 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $attary{$attname}
  385 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $attary{$attname}
  393 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $attary{$attname}
  407 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $attary{$attname}
  413 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $attary{$attname}
  449 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $repl{$matches[0][$i]}
  525 | WARNING | [ ] Function each() is deprecated since PHP 7.2; Use a
      |         |     foreach loop instead
  533 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $attary{$attname}
  546 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $attary{$attname}
  568 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $attary{$attname}
  577 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $attary{$attname}
  584 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $attary{$attname}
  678 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $body{$i}
  709 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $body{$i+2}
  828 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $divattary{"style"}
  924 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $open_tags{$tagname}
  925 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $open_tags{$tagname}
  927 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $open_tags{$tagname}
  971 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $open_tags{$tagname}
  972 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $open_tags{$tagname}
  974 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $open_tags{$tagname}
 1131 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $bad_attvals{'/.*/'}
 1131 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $bad_attvals{'/.*/'}{'/^src|background/i'}
 1135 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $bad_attvals{'/.*/'}
 1135 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $bad_attvals{'/.*/'}{'/^src|background/i'}
 1139 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $bad_attvals{'/.*/'}
 1139 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $bad_attvals{'/.*/'}{'/^style/i'}
 1143 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $bad_attvals{'/.*/'}
 1143 | WARNING | [x] Curly brace syntax for accessing array elements and
      |         |     string offsets has been deprecated in PHP 7.4. Found:
      |         |     $bad_attvals{'/.*/'}{'/^style/i'}
--------------------------------------------------------------------------------
PHPCBF CAN FIX THE 28 MARKED SNIFF VIOLATIONS AUTOMATICALLY
--------------------------------------------------------------------------------


FILE: ...ents/maarchRM/dependency/notification/PHPMailer-master/class.phpmailer.php
--------------------------------------------------------------------------------
FOUND 4 ERRORS AND 4 WARNINGS AFFECTING 8 LINES
--------------------------------------------------------------------------------
  679 | WARNING | INI directive 'mbstring.func_overload' is deprecated since
      |         | PHP 7.2
  686 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and
      |         | removed since PHP 5.4
 1435 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and
      |         | removed since PHP 5.4
 2610 | WARNING | Function get_magic_quotes_runtime() is deprecated since PHP
      |         | 7.4
 2613 | ERROR   | Function set_magic_quotes_runtime() is deprecated since PHP
      |         | 5.3 and removed since PHP 7.0
 2618 | ERROR   | INI directive 'magic_quotes_runtime' is deprecated since PHP
      |         | 5.3 and removed since PHP 5.4
 2625 | ERROR   | Function set_magic_quotes_runtime() is deprecated since PHP
      |         | 5.3 and removed since PHP 7.0
 2627 | ERROR   | INI directive 'magic_quotes_runtime' is deprecated since PHP
      |         | 5.3 and removed since PHP 5.4
--------------------------------------------------------------------------------


FILE: ...ieu/Documents/maarchRM/dependency/logger/log4php/LoggerReflectionUtils.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 71 | WARNING | Function each() is deprecated since PHP 7.2; Use a foreach loop
    |         | instead
--------------------------------------------------------------------------------


FILE: ...RM/dependency/logger/log4php/pattern/LoggerPatternConverterSuperglobal.php
--------------------------------------------------------------------------------
FOUND 1 ERROR AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 71 | WARNING | Global with anything other than bare variables is discouraged
    |         | since PHP 7.0. Found ${$this->name}
 71 | ERROR   | "$this" can no longer be used with the "global" keyword since
    |         | PHP 7.1.
--------------------------------------------------------------------------------


FILE: ...ents/maarchRM/dependency/html/plugins/lessphp/lib/Less/Exception/Chunk.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 10 WARNINGS AFFECTING 10 LINES
--------------------------------------------------------------------------------
  70 | WARNING | Targeting a 'switch' control structure with a 'continue'
     |         | statement is strongly discouraged and will throw a warning as
     |         | of PHP 7.3.
  78 | WARNING | Targeting a 'switch' control structure with a 'continue'
     |         | statement is strongly discouraged and will throw a warning as
     |         | of PHP 7.3.
  83 | WARNING | Targeting a 'switch' control structure with a 'continue'
     |         | statement is strongly discouraged and will throw a warning as
     |         | of PHP 7.3.
  89 | WARNING | Targeting a 'switch' control structure with a 'continue'
     |         | statement is strongly discouraged and will throw a warning as
     |         | of PHP 7.3.
  99 | WARNING | Targeting a 'switch' control structure with a 'continue'
     |         | statement is strongly discouraged and will throw a warning as
     |         | of PHP 7.3.
 102 | WARNING | Targeting a 'switch' control structure with a 'continue'
     |         | statement is strongly discouraged and will throw a warning as
     |         | of PHP 7.3.
 122 | WARNING | Targeting a 'switch' control structure with a 'continue'
     |         | statement is strongly discouraged and will throw a warning as
     |         | of PHP 7.3.
 127 | WARNING | Targeting a 'switch' control structure with a 'continue'
     |         | statement is strongly discouraged and will throw a warning as
     |         | of PHP 7.3.
 148 | WARNING | Targeting a 'switch' control structure with a 'continue'
     |         | statement is strongly discouraged and will throw a warning as
     |         | of PHP 7.3.
 155 | WARNING | Targeting a 'switch' control structure with a 'continue'
     |         | statement is strongly discouraged and will throw a warning as
     |         | of PHP 7.3.
--------------------------------------------------------------------------------


FILE: ...nts/maarchRM/dependency/html/plugins/lessphp/lib/Less/Exception/Parser.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
--------------------------------------------------------------------------------
 103 | WARNING | INI directive 'mbstring.func_overload' is deprecated since PHP
     |         | 7.2
--------------------------------------------------------------------------------


FILE: ...ieu/Documents/maarchRM/dependency/html/plugins/lessphp/lib/Less/Parser.php
--------------------------------------------------------------------------------
FOUND 0 ERRORS AND 4 WARNINGS AFFECTING 4 LINES
--------------------------------------------------------------------------------
  92 | WARNING | INI directive 'mbstring.func_overload' is deprecated since PHP
     |         | 7.2
  93 | WARNING | INI directive 'mbstring.internal_encoding' is deprecated since
     |         | PHP 5.6
  94 | WARNING | INI directive 'mbstring.internal_encoding' is deprecated since
     |         | PHP 5.6
 229 | WARNING | INI directive 'mbstring.internal_encoding' is deprecated since
     |         | PHP 5.6
--------------------------------------------------------------------------------




History

#1 Updated by Mathieu PIONNIER 7 months ago

  • Description updated (diff)

#2 Updated by Mathieu PIONNIER 7 months ago

  • Description updated (diff)

#3 Updated by Cyril VAZQUEZ 7 months ago

  • Target version changed from Product Backlog to 2.8

#4 Updated by Cyril VAZQUEZ 7 months ago

Signature de ReflectionClass::newInstance

Pb de typage des ReflectionParameters car changement de retour de __toString du ReflectionType (utilisé pour typer les paramètres objets en PHP 7-)

Pb d'éval des enumérations des modèles quand pas de quote autour des valeurs, semblant indiquer des constantes : [foo, bar] au lieu de ['foo', 'bar']
résolu avec un try...catch et une méthode fallback basée sur un découpage avec explode

Pb de fonction de comparaison pour tri qui renvoyait un bool au lieu d'un entier dans controller archivalProfile

#5 Updated by Cyril VAZQUEZ 6 months ago

  • Status changed from A étudier to A tester

#6 Updated by Arnaud PAUGET 6 months ago

  • Target version changed from 2.8 to 2.8.0

#7 Updated by Emmanuel DILLARD 4 months ago

  • Project changed from Maarch RM - Product Backlog to Backlog RM
  • Target version changed from 2.8.0 to 2.8
  • Tags RM 2.8.0 added

#8 Updated by Alexandre GOLDSTEIN 4 months ago

  • Status changed from A tester to A livrer

fusionné dans develop

#9 Updated by Emmanuel DILLARD 3 months ago

  • Status changed from A livrer to Intégré / Développé / Analysé

Also available in: Atom PDF