Project

General

Profile

Anomalie #13891

[Analyse] Reprise et test la synchronisation LDAP en fonction de l'arborescence de la collectivité

Added by Henri QUENEAU about 2 years ago. Updated 12 months ago.

Status:
Développé / Analysé (S)
Priority:
0-Bloquant
Assignee:
Target version:
Start date:
02/17/2020
Due date:
Tags Courrier:
19.04.15, 20.03.3

Description

Il est impossible de lancer la synchronisation ldap sur la 19.04.

Une erreur apparait :

[root@app111-20t script]# sh syn_ldap.sh
type ldap : openLDAP
string(10) "10.0.42.15"
string(65) "CN=SVCMAARCH,OU=Generique;OU=Utilisateurs,DC=reseau,DC=cg50,DC=fr"
string(8) "rW1yp5mA"
Fatal error: Uncaught ArgumentCountError: Too few arguments to function LDAP::__construct(), 4 passed in /var/www/html/MaarchCourrier/modules/ldap/process_ldap_to_xml.php on line 104 and exactly 5 expected in /var/www/html/MaarchCourrier/modules/ldap/class/class_openLDAP.php:34
Stack trace:
#0 /var/www/html/MaarchCourrier/modules/ldap/process_ldap_to_xml.php(104): LDAP->__construct('10.0.42.15', 'CN=SVCMAARCH,OU...', 'rW1yp5mA', false)
#1 {main}
thrown in /var/www/html/MaarchCourrier/modules/ldap/class/class_openLDAP.php on line 34
[root@app111-20t script]#

Aucune piste par l'équipe projet. passage au support niveau 3 afin d'être aidé

ldap.tar.gz (263 KB) ldap.tar.gz Henri QUENEAU, 05/11/2020 07:22 PM

History

#2 Updated by Henri QUENEAU about 2 years ago

le paquet ldap contient les scripts de synchronisation ldap du module de la version 1.4 (et non de la 19.04)

#3 Updated by Emmanuel DILLARD about 2 years ago

  • Status changed from A qualifier to A traiter
  • Assignee changed from Henri QUENEAU to EDI PO

#4 Updated by Emmanuel DILLARD about 2 years ago

  • Status changed from A traiter to Prêt à développer

#5 Updated by Emmanuel DILLARD about 2 years ago

  • Project changed from Backlog to CURRENT SPRINT
  • Subject changed from Reprise et test la synchronisation LDAP en fonction de l'arborescence de la collectivité to [Analyse] Reprise et test la synchronisation LDAP en fonction de l'arborescence de la collectivité
  • Status changed from Prêt à développer to En cours de dev (S)

#6 Updated by Emmanuel DILLARD about 2 years ago

  • Target version changed from 19.04 (Support sécurité) to 20.10 Develop
  • Tags Courrier 19.04.15, 20.03.3 added

#8 Updated by Florian AZIZIAN about 2 years ago

  • Assignee deleted (EDI PO)

#9 Updated by Guillaume HEURTIER about 2 years ago

  • Assignee set to Guillaume HEURTIER

#10 Updated by Guillaume HEURTIER about 2 years ago

  • Status changed from En cours de dev (S) to Développé / Analysé (S)

#12 Updated by Emmanuel DILLARD about 2 years ago

  • Assignee changed from Guillaume HEURTIER to Henri QUENEAU

#13 Updated by Henri QUENEAU almost 2 years ago

  • Assignee changed from Henri QUENEAU to EDI PO

Pourquoi ce ticket m'est revenu?

Vu que la branche 19.04.15 n'est pas encore sortie?

Pour le moment je ne peux toujours pas avancer

#14 Updated by Emmanuel DILLARD almost 2 years ago

  • Assignee changed from EDI PO to Henri QUENEAU

C'est l'info que cette anomalie à été prise en compte et corrigée dans les tags (version corrective).

Le 19.04.15 est prévu pour le 15/06.
cf : https://docs.google.com/spreadsheets/d/12pQkzL4LoSPaPhHK1p4D3aglVYwILFdttMvNTlGK_14/edit?usp=sharing

#15 Updated by Emmanuel DILLARD almost 2 years ago

  • Project changed from CURRENT SPRINT to Backlog

#16 Updated by Emmanuel DILLARD 12 months ago

  • Project changed from Backlog to Backlog Courrier
  • Target version changed from 20.10 Develop to 20.10 (Actif)

Also available in: Atom PDF